Добро пожаловать в EMS Data Comparer!

EMS Data Comparer for PostgreSQL – мощная и удобная программа для сравнения и синхронизации данных PostgreSQL. С помощью этой утилиты вы можете просматривать все различия в сравниваемых таблицах PostgreSQL и запускать автоматически исполняемый сценарий для устранения различий. Гибкие параметры настройки процессов сравнения и синхронизации данных PostgreSQL позволяют выбирать таблицы и поля для сравнения, выполнять частичное сравнение и синхронизацию нескольких таблиц одновременно, а также настраивать другие опции для эффективного сравнения таблиц PostgreSQL. Data Comparer for PostgreSQL включает графический мастер, который поэтапно проведет вас через процессы сравнения/синхронизации, и консольную утилиту для автоматической синхронизации данных PostgreSQL.

Ключевые особенности

  • Простой и понятный интерфейс мастера настройки
  • Возможность сравнения данных для нескольких таблиц одновременно
  • Автоматическая и ручная выборка данных для сравнения
  • Огромный диапазон параметров синхронизации
  • Поддержка данных в формате Unicode
  • Частичная синхронизация данных
  • Сохранение сценария синхронизации в файл для дальнейшего использования
  • Возможность сохранения всех параметров, заданных в активной сессии
  • Консольная утилита, использующая конфигурационные файлы для сравнения и синхронизации данных
  • Возможность сравнения данных с использованием фильтров
  • Поддержка всех типов данных PostgreSQL

Посетите наш сайт: http://www.sqlmanager.net/.

Информация по продукту

Домашняя страница: | http://www.sqlmanager.net/ru/products/postgresql/datacomparer
Служба поддержки: | http://www.sqlmanager.net/support
Регистрация: | http://www.sqlmanager.net/ru/products/postgresql/datacomparer/buy


Новости

Версия | Дата выпуска
Data Comparer for PostgreSQL 3.5.3 | 09.02.2023

Что нового в Data Comparer 3.5.3?

  • Добавлена поддержка версии сервера PostgreSQL 15.
  • Другие небольшие изменения и улучшения.

Смотрите также:

История версий


Системные требования

  • Microsoft Windows NT4 c SP4 или более поздней версией, Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows 2008 Server, Microsoft Windows Vista, Microsoft Windows 7, Microsoft® Windows 8, Microsoft® Windows 8.1, Microsoft® Windows 10, Microsoft Windows 11
  • 512 MB RAM (рекомендуется 128 MB или более)
  • 50 Mб свободного пространства на жестком диске для установки программы
  • Возможность соединения с локальным или удаленным сервером PostgreSQL
  • Поддерживаемые версии сервера PostgreSQL: с 7.3 по 15.0


Установка

Установка программы

  • загрузите установочный файл программы со страницы загрузки,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • откройте файл PgDataComparerSetup.exe и следуйте инструкциям мастера установки,
  • после завершения процесса установки ярлыки программы находятся в Пуск->Программы->EMS.

Часто задаваемые вопросы по установке ПО

Обновление программы

  • загрузите установочный файл программы со страницы загрузки сайта,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • закройте программу Data Comparer for PostgreSQL, если она запущена,
  • запустите файл PgDataComparerSetup.exe и следуйте инструкциям мастера обновления

Смотрите также:

Системные требования


Приобретение

Чтобы упростить процесс приобретения наших продуктов, мы заключили контракт с Интернет-регистратором Digital River. Процедура совершения покупки через Share-it! защищена безопасным соединением и делает процесс оплаты быстрым и безопасным.

Если Вы заказали программное обеспечение компании EMS в Интернет и хотели бы посмотреть информацию о Вашем заказе, или же если у Вас возникли вопросы, касающиеся приобретения наших продуктов, оплаты или процедуры доставки, пожалуйста, обратитесь в техническую поддержку, обслуживаемую компанией Digital River.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery). Сделав заказ, Вы сможете немедленно скачать регистрационные ключи или пароли и ссылки на архивы полных версий программ. Также Вы получите копию регистрационных ключей или паролей по электронной почте.

Если при оформлении не получили регистрационный ключ в течение двух часов, обратитесь в службу поддержки по этому адресу sales@sqlmanager.net.

Если Вы являетесь зарегистрированным пользователем, то при возникновении проблем или вопросов при использовании нашего программного обеспечения обращайтесь в службу поддержки.

Описание продукта | MyCommerce/Digital River
EMS Data Comparer for PostgreSQL (Бизнес лицензия) + 1 Год Сопровождения* | Отправить запрос!
EMS Data Comparer for PostgreSQL (Бизнес лицензия) + 2-Года Сопровождения*
EMS Data Comparer for PostgreSQL (Бизнес лицензия) + 3-Года Сопровождения*
EMS Data Comparer for PostgreSQL (Некоммерческая лицензия) + 1-Год Сопровождения*
EMS Data Comparer for PostgreSQL (Некоммерческая лицензия) + 2-Года Сопровождения*
EMS Data Comparer for PostgreSQL (Некоммерческая лицензия) + 3-Года Сопровождения*
EMS Data Comparer for PostgreSQL (Пробная версия) | Загрузить!

* Программа EMS по Сопровождению ПО это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО. Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Мгновенное возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО

Смотрите также:

Регистрация


Регистрация

Чтобы зарегистрировать только что приобретенную копию программы необходимо выполнить следующие действия:

  • получить уведомительное письмо с регистрационной информацией из Digital River
  • ввести Registration Name и Registration Key из этого письма в соответсвующие поля;
  • убедиться, что регистрация прошла успешно - проверить наличие регистрационного имени и пароль на стартовой странице. В этом окне должны отображаться введенные вами Registration Name и Registration Key.

После введения правильного регистрационного ключа появляется информационное окно, сообщающее о том, что Вы теперь имеете право пользоваться программой.

Welcome to Data Comparer - Register product

Смотрите также:

Приобретение

Регистрация


История версий

Наименование продукта | Версия | Дата выпуска
Data Comparer for PostgreSQL | Версия 3.5.2 | 13.02.2020
Data Comparer for PostgreSQL | Версия 3.5.1 | 27.07.2016
Data Comparer for PostgreSQL | Версия 3.5.0 | 16.11.2012
Data Comparer for PostgreSQL | Версия 3.4.0.1 | 7.03.2012
Data Comparer 2011 for PostgreSQL | Версия 3.3.0.1 | 29.08.2011
Data Comparer 2011 for PostgreSQL | Версия 3.2.0.1 | 21.03.2011
Data Comparer 2010 for PostgreSQL | Версия 3.1.0.1 | 01.11.2010
Data Comparer 2010 for PostgreSQL | Версия 3.0.0.1 | 04.05.2010
Data Comparer 2010 for PostgreSQL | Версия 2.3.0.1 | 10.03.2009
Data Comparer 2007 for PostgreSQL | Версия 2.2.0.1 | 02.10.2008
Data Comparer 2007 for PostgreSQL | Версия 2.1.0.1 | 19.12.2007
Data Comparer 2007 for PostgreSQL | Версия 2.0.0.1 | 15.02.2007
Data Comparer 2005 for PostgreSQL | Версия 1.2.0.1 | 30.05.2006
Data Comparer 2005 for PostgreSQL | Версия 1.1.0.1 | 14.03.2006

Полную историю версий Вы можете посмотреть по следующей ссылке: http://www.sqlmanager.net/products/postgresql/datacomparer/news.

Версия 3.5.2

  • Добавлена поддержка версий серверов SQL Server 2017, MySQL Server 8, PostgreSQL 12.
  • Добавлена поддержка Azure SQL Database.
  • FB/IB. Исправлена синхронизация данных типа TIME и DATETIME с миллисекундами.
  • FB/IB. Добавлена поддержка типа BOOLEAN.
  • FB/IB. Теперь триггеры для таблиц отключаются корректно.
  • MySQL. Исправлена ошибка 'MySQL has gone away' при работе программы.
  • PostgreSQL. При пересоздании внешних ключей теперь корректно обрабатывается опция MATCH.
  • Другие изменения и улучшения.

Версия 3.5.1

  • Значительно увеличена производительность программы.
  • Увеличена скорость сравнения данных BLOB.
  • Теперь поля BINARY можно выбирать в качестве ключевых для сравнения данных.
  • Не обновлялся список полей при смене выбранных таблиц. Исправлено.
  • Заданная кодировка не применялась к создаваемому скрипту. Исправлено.
  • Исправлены ошибки загрузки файла шаблона.
  • Другие улучшения и исправления ошибок.

Версия 3.5.0

  • Добавлена возможность ручной настройки списка синхронизируемых записей.
  • Добавлена проверка синхронизируемых таблиц на наличие в них триггеров. Если триггеры присутствуют в целевой таблице, будет выдан запрос на их отключение.
  • Добавлена возможность задания фильтров на основе оператора LIKE.
  • На шаге установления соответствий таблиц появилась возможность просмотра фильтра в виде всплывающего окна.

Версия 3.4.0.1

  • Результаты сравнения теперь можно экспортировать в формат MS Excel 2007.
  • Окно прогресса теперь показывает оставшееся время и количество обработанных записей в секунду.
  • В фильтр данных добавлены операции OR и AND.
  • Существенно увеличена скорость сравнения таблиц при выборе текстовых полей в качестве ключевых (Key fields).
  • Добавлена возможность сохранения шаблона на любом шаге мастера.
  • Прочие улучшения и исправления.

Версия 3.3.0.1

  • Добавлена возможность сравнивания данных с использованием фильтров;
  • Добавлена опция "Trim CHAR Fields", которая позволяет обрезать пробелы в полях CHAR и NCHAR при сравнении и синхронизации;
  • Добавлен список переходов (Jump List) со списком шаблонов для Windows 7;
  • Теперь если при синхронизации данных сервер возвращает меньшее количество обработанных записей, чем предполагалось синхронизировать (например, из-за триггеров), в журнал пишется предупреждение;
  • В консольной версии добавлен параметр пути к журналу;
  • Прочие улучшения и исправления.

Версия 3.2.0.1

  • Оптимизировано использование ОЗУ. Теперь программа потребляет заметно меньше памяти при работе с большими таблицами.
  • Добавлена новая опция "Fill correspondence automatically" для консольной версии, задающаяся при сохранении шаблона. При ее включении, во время сравнения баз, новые таблицы (созданные после генерации шаблона) будут также сравниваться и синхронизироваться.
  • При загрузке шаблона теперь может при необходимости запрашиваться пароль к базе данных.
  • Добавлена опция шифрования пароля в шаблоне, задающаяся при сохранении файла шаблона.
  • Иногда неправильно сортировались данные в таблицах при отображении результата сравнения. Исправлено.
  • При синхронизации баз данных, находящихся на одном сервере, появилась возможность генерации скриптов синхронизации, содержащих данные таблиц как если бы базы находились на разных серверах. Для этого надо отключить опцию "Fast synchronization (on server side)".
  • Добавлены подсказки к опциям на формах приложения.
  • Прочие изменения и улучшения.

Версия 3.1.0.1

  • Добавлена опция Disable foreign keys на Шаге 4 - Задание параметров синхронизации данных, которая позволяет отключать внешние ключи при вставке и модификации данных.
  • Добавлена опция Disable triggers на Шаге 4 - Задание параметров синхронизации данных. Эта опция позволяет отключать триггеры при вставке и изменении данных.
  • Скрипт до синхронизации ("Before synchronization script") и скрипт после синхронизации ("After synchronization script") на Шаге 7 - Задание дополнительных скриптов теперь выполняются в контексте того же подключения, что и синхронизация.
  • В редакторе скриптов при сохранении и открытии сохраняется последняя выбранная кодировка.
  • Теперь, в случае возникновения ошибок базы данных в процессе сравнения, программа сообщает об ошибке и предлагает продолжить. Текст ошибок, произошедших в результате сравнения, показывается в диалоговом окне Summary в виде всплывающей подсказки.
  • В Редактор BLOB добавлена возможность просмотра текста в кодировке Unicode.
  • Выбор таблиц для синхронизации теперь стал удобнее.
  • Добавлена возможность отключения опции сворачивания кода (Code folding) в редакторах.
  • Добавлена возможность экспорта результатов сравнения сразу всех таблиц.
  • Добавлена возможность использовать фильтры при автозаполнении.
  • Прочие улучшения и исправления.

Версия 3.0.0.1

  1. Реализован новый улучшенный алгоритм сравнения и синхронизации, оптимизированный для работы с большими базами данных, благодаря которому:
  • существенно увеличена скорость сравнения, в некоторых случаях до 5 раз;
  • увеличена скорость синхронизации, особенно для случая, когда сравниваемые таблицы располагаются на одном сервере;
  • сильно снижена величина потребляемой оперативной памяти, и теперь она не зависит от числа записей в сравниваемых таблицах, что раньше могло приводить к ошибке “Out of Memory”;
  • увеличена скорость автозаполнения таблиц и полей.
  2. Добавлена возможность синхронизации BLOB полей в InterBase.
  3. Добавлена кнопка просмотра итогов сравнения “Summary” на Шаге 3 - Просмотр результатов сопоставления данных.
  4. Синхронизация с удалением записей в таблицах с внешними ключами могла приводить к ошибке. Исправлено.
  5. Добавилась возможность очистки списка шаблонов.
  6. Прочие улучшения и исправления.

Версия 2.3.0.1

  • Добавлена опция Commit after synchronization, которая позволяет откатить все изменения при возникновении ошибки в процессе синхронизации.
  • Добавлена возможность вручную задавать порядок синхронизации таблиц.
  • Добавлена возможность вывода итогового отчета по результатам сравнения таблиц.
  • Добавилась возможность фильтрации и сортировки результатов сравнения.
  • Поля доменного типа нельзя было выбирать в качестве ключа сравнения. Исправлено.
  • Исправлена ошибка неверного чтения зашифрованных паролей старых версий шаблонов.
  • Другие исправления и улучшения.

Версия 2.2.0.1

  • Добавлена возможность экспорта отчетов сравнения в форматы HTML и RTF.
  • Добавлена поддержка сервера PostgreSQL 8.3.
  • Оптимизирован алгоритм обработки массивов.
  • Новый улучшенный Редактор сценариев.
  • Появилась возможность вывода детального описания ошибок в Консольном приложении.
  • Оптимизирован алгоритм создания сценариев: теперь в сценарий синхронизации добавляются только отличающиеся поля.
  • Добавилась возможность сохранения и печати журналов синхронизации.
  • Другие исправления и улучшения.

Версия 2.1.0.1

  • Теперь вы можете создавать пакеты SQL команд, которые будут выполняться до запуска процесса синхронизации и/или после его завершения.
  • Добавлена возможность выбора схем БД для сравнения данных.
  • Поля типа ‘serial’ теперь устанавливаются в значение ‘nextval’ после завершения синхронизации.
  • Значительно увеличена скорость синхронизации таблиц, для которых выбранный набор ключевых полей отличается от набора полей, входящих в первичный ключ.
  • Списки таблиц теперь сортируются по имени схемы и имени таблицы.
  • Добавилась возможность сохранения журнала синхронизации в файл.
  • Количество устанавливаемых соединений с БД теперь равно количеству выбранных потоков.
  • Прочие улучшения и исправления.

Наверх

Версия 2.0.0.1

  • Добавлена возможность сравнения нескольких пар таблиц одновременно благодаря использованию потоков. Число одновременно работающих потоков задается пользователем. Сравнение большого числа таблиц в этом случае происходит быстрее.
  • Для SSH туннелирования добавлена поддержка ключей.
  • Значительно увеличена скорость синхронизации благодаря оптимизации механизмов сравнения.
  • Более удобный просмотр различий в данных таблиц. Данные таблиц отображаются в отдельных сетках, которые синхронно листаются при навигации по записям.
  • Модификация данных производится с учетом зависимостей между таблицами (учитываются внешние ключи).
  • Добавлена возможность поиска в Редакторе SQL.
  • Добавлена возможность отбора таблиц для синхронизации после сравнения данных.
  • Выгрузка результатов сравнения в Excel.
  • Добавлена опция "Detailed error messages" на шаге синхронизации. При ее включении, в случае возникновения ошибки в процессе модификации данных в лог будет выводиться SQL команда, ее вызвавшая.
  • Шифрование паролей в файлах шаблонов и в реестре.
  • Добавлена поддержка данных в кодировке UTF-8
  • Более удобный и дружественный интерфейс.
  • Множество доработок и исправлений.

Наверх

Версия 1.2.0.1

  • Добавилась возможность соединения с использованием туннеля HTTP.
  • Добавлена возможность просмотра/редактирования сценария синхронизации в редакторе скриптов.
  • Добавлена опция синхронизации 'Drop and create indexes'.
  • Для полей, не входящих в список сравниваемых, будут применяться значения по умолчанию (в предыдущих версиях применялись значения NULL).
  • Теперь возможно прервать синхронизацию при возникновении ошибки при помощи соответствующей опции.
  • Консольное приложение теперь может быть запущено в фоновом режиме.
  • Прочие незначительные улучшения и исправления ошибок.

Наверх

Версия 1.1.0.1

  • Встроен новый инструмент просмотра BLOB-полей.
  • Увеличена скорость сравнения данных.
  • Добавлена возможность просмотра информации о соединении.
  • Добавлена опция "Use only compare key for where clause" для генерации сценария SQL.
  • Добавлена опция "Add computed and read only fields to the new table" для генерации выражений CREATE TABLE.
  • Автоматическая установка первичных ключей для сравниваемых полей.
  • Реализовано выделение цветом отличающихся записей.
  • Добавлена опция "Commit after XXX records" для вставки оператора COMMIT после заданного числа изменяющих операторов SQL.
  • Прочие незначительные улучшения и исправления ошибок.

Наверх

Смотрите также:

Новости


Часто задаваемые вопросы

Что такое Data Comparer for PostgreSQL?

Что необходимо для начала работы с EMS Data Comparer for PostgreSQL?

Как проще всего сконфигурировать файлы-шаблоны для консольного приложения Data Comparer?

Как зарегистрировать приложение?

Есть ли какие-нибудь ограничения в ознакомительной версии, по сравнению с полной версией?

Как можно автоматизировать процесс сравнения и синхронизации?

В: Что такое Data Comparer for PostgreSQL?

О: EMS Data Comparer for PostgreSQL – мощная и удобная программа для сравнения и синхронизации данных PostgreSQL. С помощью этой утилиты вы можете просматривать все различия в сравниваемых таблицах PostgreSQL и запускать автоматически исполняемый сценарий для устранения различий.

В: Что необходимо для начала работы с EMS Data Comparer for PostgreSQL?

О: Во-первых, Вы должны иметь возможность подключиться к локальному или удаленному PostgreSQL серверу для работы с Data Comparer. Вы можете загрузить PostgreSQL сервер баз данных отсюда http://www.postgresql.org/download/. Кроме того, необходимо, чтобы Ваш компьютер удовлетворял Системным требованиям Data Comparer for PostgreSQL.

В: Как проще всего сконфигурировать файлы-шаблоны для консольного приложения Data Comparer?

О: Сконфигурировать файлы-шаблоны проще всего визуально, используя Data Comparer Wizard. Настройте необходимые параметры для каждого шага и нажмите Tools | Save template. Все настройки будут сохранены в файле-шаблоне, который может быть использован консольным приложением.

В: Как зарегистрировать приложение?

О: Если Вы приобрели Data Comparer for PostgreSQL, то зарегистрировать его Вы можете, введя полученные имя и регистрационный код на стартовой странице. Смотрите дополнительно Приобретение и Регистрация.

В: Есть ли какие-нибудь ограничения в ознакомительной версии, по сравнению с полной версией?

О: Ознакомительная версия позволяет сравнивать и синхронизировать не более 10 таблиц. В остальном функционал ознакомительной версии не отличается от полной версии. Вы можете использовать ознакомительную версию в течение тридцати дней бесплатного тестового периода.

В: Как можно автоматизировать процесс сравнения и синхронизации?

O: Пройдите все шаги мастера, задавая необходимые настройки и сохраните шаблон проекта на последнем шаге. Шаблон может быть запущен с помощью консольной версии утилиты из командной строки. Для автоматического выполнения проекта по расписанию необходимо настроить запуск консольной версии, передавая имя шаблона параметром, используя стандартные Назначенные задания в Windows.

Наверх

При возникновении новых вопросов, обратитесь в Службу поддержки.


Сопутствующие продукты

MySQL

Microsoft SQL Server

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL Server

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for PostgreSQL EMS SQL Backup for PostgreSQL — это простой в использовании визуальный инструмент для создания резервных копий для нескольких серверов PostgreSQL из единой консоли. Вы можете создавать автоматизированные задачи резервного копирования на основе расписаний и хранить их в локальных или удаленных папках или облачных хранилищах.
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

IBM DB2

 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
 | Наверх


Использование мастера сравнения и синхронизации данныx

Мастер сравнения и синхронизации данных позволит Вам быстро просматривать все различия в сравниваемых таблицах PostgreSQL и запускать автоматически исполняемый сценарий для устранения различий. На каждом его шаге необходимо указывать определенные параметры сравнения и синхронизации.

Начало работы

Шаг 1 - Установка параметров подключения

Шаг 2 - Установка соответствия полей

Шаг 3 - Просмотр результатов сопоставления данных

Шаг 4 - Задание параметров синхронизации данных

Шаг 5 - Задание порядка синхронизации таблиц

Шаг 6 - Просмотр и исправление скрипта

Шаг 7 - Задание дополнительных скриптов

Шаг 8 - Выполнение операции

Смотрите также:

Работа с консольным приложением

Использование шаблонов

Настройка программы


Начало работы

Так выглядит Data Comparer for PostgreSQL при первом запуске.

На этой форме Вы можете просмотреть регистрационную информацию, или, нажав кнопку Enter Registration Code, ввести имя и регистрационный ключ в появившемся окне.

Если регистрационный ключ указан правильно, то появится сообщение о дате окончания периода сопровождения.

Если копия программы не зарегистрирована, то в нижней части формы отображается количество дней, оставшихся до окончания действия ознакомительной копии.

Application wizard - Getting started

Нажмите кнопку Next для перехода к первому шагу мастера экспорта данных.

Смотрите также:

Приобретение

Регистрация


Шаг 1 - Установка параметров подключения

На этом шаге укажите параметры подключения к базам данных PostgreSQL.

В разделе Source Database Connection Parameters укажите параметры подключения к исходной базе данных.

В разделе Target Database Connection Parameters задайте настройки подключения к назначенной базе данных.

Если обе базы находятся на одном сервере, то установите флажок Both databases on the same server. В этом случае Параметры подключения Вам нужно будет указать только один раз.

Step 1 - Setting connection properties

В разделе Connection type выберите тип соединения с сервером.

RadioButton Local - локальное соединение (сервер установлен на этом компьютере)

RadioButton Remote - соединение с сервером по сети

В разделе Authorization укажите параметры авторизации пользователя на сервере. Имя указывается в поле Login, пароль - в поле Password. По имени и паролю система определяет ваши права доступа к информации, и, в соответствии с этим, разрешает доступ к объектам.

Из раскрывающегося списка Host выберите сервер (хост), к которому хотите подключиться. В этот список попадают имена уже зарегистрированных серверов. В поле Connection Port задайте порт для подключения.Набор символов выберите из раскрывающегося списка Client Charset. Эти правила задают кодовую страницу и порядок сопоставления символьных данных для работы с данными в Юникоде и других форматах.

Базу данных выберите из раскрывающегося списка Database с помощью кнопки btnEllipsis.

Если Вы используете версию Data Comparer for PostgreSQL для EMS SQL Management Studio for PostgreSQL, то на первом шаге доступна кнопка Select registered database, при нажатии на которую открывается диалог выбора базы данных из зарегистрированных в EMS SQL Management Studio.

На вкладке Tunneling задайте параметры туннелирования.

SSH туннелирование будет использовано если установлен RadioButton Connect through the Secure Shell (SSH) tunnel,

Используйте SSH туннелирование для осуществления обмена данными с сервером по шифрованному каналу.

SSH host name - имя машины (IP-адрес), на которой установлен сервер SSH.

SSH port - порт SSH сервера на удаленном хосте (по умолчанию равен 22).

SSH user name - имя пользователя на сервере (пользователь SSH сервера, а не сервераPostgreSQL).

SSH password - пароль пользователя SSH сервера.

Step 1 - Setting connection properties - Tunneling

Если установлен флажок Use Private Key for authentication, то в поле SSH key file можно указать ключевой файл для аутентификации.

Для доступа к PostgreSQL серверу через HTTP протокол выберите HTTP туннелирование, установив переключатель Connect through the HTTP tunnel.

Дополнительную информацию о настройках подключения смотрите на странице Параметры HTTP туннелирования.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации,
  • открыть файл конфигурации.

Нажмите кнопку Next, чтобы перейти к выбору схем для обновления или непосредственно ко второму шагу (если не установлен флажок Show schema selection dialog на вкладке General в настройках программы).


Выбор баз данных

После того, как установлены все параметры соединения, необходимо выбрать базу данных, используя диалоговое окно Select database.

Чтобы открыть это окно необходимо нажать кнопку btnEllipsis в поле Database на первом шаге.

Step 1 - Selecting database

Выберите базу данных из списка и нажмите кнопку OK.


Выбор схем

Прежде чем перейти ко второму шагу, необходимо указать схемы сравниваемых баз данных, которые будут обновлены. Для этого воспользуйтесь диалоговым окном Select schemas for refreshing.

Важно: Контекстное меню доступно для работы как со списком исходных схем - Source schemas list, так и со списком назначенных схем - Target schemas lists.

Контекстное меню

iconCheckAll Check all - выделить всё,

iconUncheckAll Uncheck all - убрать выделение.

iconInvertSelection Invert items - обратить выделение.

Step 1 - Selecting schemas for refreshing

CheckBox Refresh all schemas and don't show this window in the future

Если установлен этот флажок, то все схемы будут обновляться автоматически, а это окно больше не будет отображаться при следующих запусках программы.

Важно: Чтобы активировать этот диалог, установите флажок Show select schemas window на вкладке General в Настройках программы.

Нажмите кнопку OK, чтобы перейти ко второму шагу мастера.


Выбор зарегистрированной базы данных

В этом диалоге выберите базу данных для сравнения. Этот диалог доступен только в версии Data Comparer for PostgreSQL для EMS SQL Management Studio.

Selecting registered database

В этом списке отображаются все базы данных, зарегистрированные в EMS SQL Management Studio.

Выберите нужную базу и нажмите кнопку OK.

Регистрационная информация базы данных автоматически появится в соответствующих полях на первом шаге.


Шаг 2 - Установка соответствия таблиц и полей

На этом шаге выберите объекты для сравнения данных.

Step 2 - Setting tables and fields correspondence

Setting table correspondence

В этом разделе укажите соответствие между таблицами баз данных.

Для установки соответствия таблиц можно использовать фильтр. В поле Mask for autofill можно задать параметры отбора объектов по имени.

Можно использовать следующие маски: звездочку(*), знак процента (%) или знак вопроса (?). Чтобы исключить имена объектов, используется восклицательный знак (!) в начале.

Например: условие !T * означает, что отобраны будут все объекты, кроме объектов имена которых начинаются на Т.

Автоматически установить соответствия между таблицами и полями можно с помощью кнопки Autofill tables and fields. Соответствие будет устанавливаться в соответствии с именем объекта.

В списке Source tables отображаются таблицы исходной базы данных.

Для каждой таблицы исходной базы данных из раскрывающегося списка выберите соответствующую таблицу в назначенной базе данных.

Data filter

Для задания фильтра данных используйте кнопку [image] в столбце Data Filter. Сравнение и синхронизация данных будет производится только в пределах указанного диапазона.

Используйте кнопки Data Filter - Add или Data Filter - Remove для добавления или удаления условий. Имена полей и операторы сравнения можно выбрать из выпадающих списков.

Важно: Можно задать оператор, который будет использоваться между условиями.

Step 2 - Data Filter

Setting field correspondence

В этом разделе укажите соответствие между полями выбранных таблиц.

Если Вы хотите установить соответствие между полями автоматически, то нажмите кнопку Autofill fields. В качестве идентификатора для соответствия полей используется тип данных.

Укажите ключевые поля, установив флажки напротив них в поле Key Field. По этому ключевому полю будут сравниваться данные в таблицах. Установить ключевое поле Вы можете только после того, как установлено соответствие полей.

Важно: Вы можете задать настройки сравнения для нескольких таблиц или полей одновременно, используя контекстное меню, которое открывается при нажатии правой кнопкой мыши на таблице.

Важно: Для каждой пары таблиц можно задать несколько ключевых полей.

Если для таблицы не выбраны ключевое поле, то она подсвечивается красным.

Для ключевых полей PK и UK используются разные иконки.

Ключевые поля подставляются автоматически, на основе существующих ключей.

CheckBox Ignore case when comparing strings

Установите этот флажок, если можно не учитывать регистр символов при сравнении данных.

CheckBox Compare BLOB values

Установите этот флажок, если хотите, чтобы поля BLOB сравнивались. При этом поля BLOB не синхронизируются.

CheckBox Trim CHAR fields

Если опция включена, то пробелы в конце строк для CHAR полей будут удаляться. Если данные содержат только пробелы, то они будут восприниматься как пустая строка (''). При выключенной опции все пробелы в конце строк сохраняются.

Существует возможность многопоточного сравнения. Для этого в поле Number of comparison threads укажите количество потоков.

По окончании процедуры сравнения появится диалог Summary, содержащий общую информацию о результатах процедуры. В соответствующих столбцах Вы найдете количество записей: идентичных - Identical, отличающихся Different, не найденных в исходной таблице - Missing, не найденных в назначенной таблице - Additional.

Step 2 - Summary report

Флажок Do not show summary следует поставить, если Вы не хотите, чтобы данный диалог выводился по окончании процедуры сравнения. Опция Show summary dialog after comparison в разделе настройки программы (preferences) позволяет включить/выключить появление данного диалога. Столбцы таблицы результатов можно сортировать при помощи нажатия мышкой на заголовок столбца.

Нажмите кнопку Next, чтобы перейти к следующему шагу.


Контекстное меню

Для удобства работы с таблицами соответствий существуют контекстные меню, которые открываются при нажатии правой кнопкой мыши на таблицу указания соответствий таблиц или полей на втором шаге.

Контекстное меню для раздела установки соответствия таблиц:

Step 2 - Tables grid - Context menu

  • Clear all correspondences - удалить все соответствия таблиц,
  • Clear selected correspondence(s) - удалить выделенные соответствия (Выделить несколько строк можно с помощью мышки, удерживая при этом клавиши Ctrl или Shift),
  • Fill correspondence(s) for selected object(s) - автоматически установить соответствие для выделенных объектов.

Контекстное меню раздела установки соответствия полей:

Step 2 - Fields grid - Context menu

  • Clear all field correspondences - удалить все соответствия полей.
  • Clear selected correspondence(s) - удалить выделенные соответствия (Выделить несколько строк можно с помощью мышки, удерживая при этом клавиши Ctrl или Shift),
  • Set all fields as key - отметить все поля как ключевые,
  • Unset all fields as key - убрать все отметки о ключевых полях.


Шаг 3 - Просмотр результатов сопоставления данных

На этом шаге представлены результаты сравнения данных в таблицах.

Step 3 - Browsing data comparison results

Table name

Из этого раскрывающегося списка выберете одну из пар сравниваемых таблиц, указанных на втором шаге.

В столбце Synchronize флажками отмечены пары, которые надо сравнивать.

Step 3 - Browsing data comparison results_Synchronize

Заголовок ключевого поля, указанного на предыдущем шаге, выделен жирным шрифтом.

В таблице результатов сравнения все строки данных разделены на несколько групп, обозначенных разными цветами.

Записи, идентичные в обеих таблицах.

Отличающиеся записи. В некоторых ячейках не совпадает текст (отличающийся текст выделен жирным).

Записи, не найденные в исходной таблице.

Записи, не найденные в назначенной таблице.

Важно: чтобы просмотреть данные BLOB, Вы можете воспользоваться встроенным просмотрщиком.

Чтобы отсортировать данные, просто кликните на заголовке нужного столбца.

Вы можете фильтровать записи, которые будут синхронизированы. Для этого отметьте галками те записи, которые хотите изменить в целевой таблице.

Для фильтрации данных доступны следующие опции:

CheckBox View identical records

Вы можете убрать этот флажок, чтобы скрыть идентичные записи.

CheckBox View different records

Установите флажок для отображения отличающихся записей.

CheckBox Missing records

Включите опцию, чтобы сделать видимыми записи не найденные в исходной таблице.

CheckBox Additional records

Включите опцию, чтобы сделать видимыми записи не найденные в назначенной таблице.

Number of records on page

В этом счетчике укажите количество записей, отображаемых на одной странице.

Используйте кнопки btnGoToFirstPage btnGoToPreviousPage btnGoToNextPage btnGoToLastPage для перемещения между страницами.

Чтобы применить изменения, внесенные с помощью элементов управления CheckBox View identical records и Number of records on page, и обновить результаты сравнения, нажмите кнопку btnRefresh.

Summary

Нажав на кнопку Summary, Вы можете просмотреть общие итоги сравнения в появившемся окне.

Step 3 - Browsing data comparison results_summary

При возникновении ошибки строка выделяется красным. Тип ошибки отображается в подсказке, всплывающей при наведении курсора на ошибку.

При необходимости, Вы можете экспортировать результаты в MS Excel, HTML, RTF или MS Excel 2007 нажав на кнопку iconExportResultList Export, и указав необходимые настройки в появившемся окне.

Нажмите кнопку Next, чтобы перейти к следующему шагу.


Просмотр данных типа BLOB

Data Comparer for PostgreSQL предоставляет специальный инструмент для просмотра сравниваемых BLOB (Binary Large Object) полей.

Этот инструмент может быть вызван из таблицы данных на третьем шаге с помощью нажатия на кнопку btnEllipsis, которая появляется в поле типа BLOB при его выделении.

Просмотрщик BLOB полей доступен только в том случае, если эти поля сравнивались. Включить сравнение полей такого типа можно на втором шаге.

При работе с просмотрщиком полей типа BLOB, Вы можете выбирать нужные поля из раскрывающегося списка, располагающегося в левом верхнем углу окна быстрой навигации.

Этот список позволяет быстро переключиться между полями исходной и назначенной таблицы.

BLOB viewer - Navigation in BLOB viewer

Просмотр в шестнадцатеричном представлении

На вкладке Hexadecimal Вы можете просмотреть и отредактировать информацию, содержащуюся в одной ячейке поля типа BLOB. В левой части формы содержимое ячейки представлено в шестнадцатеричном виде (шестнадцатеричные значения байтов), а в правой - в виде обычного текста.

BLOB viewer - Viewing as Hexadecimal

Просмотр в виде текста

На вкладке Text содержимое ячейки представлено в виде обычного текста.

BLOB viewer - Viewing as Text

Из раскрывающегося списка Encoding можно выбрать кодировку текста.

Просмотр в виде Rich Text

На вкладке Rich Text текст представлен в виде RTF (Rich Text Format).

BLOB viewer - Viewing as Rich Text

Просмотр в виде изображения

Если поле в базе данных имеет тип image, то просматривать его можно на вкладке Image.

Просмотр в виде HTML

Если тип данных в ячейке HTML (Hyper-Text Markup Language), то просматривать его можно на вкладке HTML.

BLOB viewer - Viewing as HTML

Просмотр в виде Multimedia

Если Данные являются аудио или видео файлом, то Вы можете просматривать их на вкладке Multimedia

С помощью кнопок btnMultimediaPlay Play btnMultimediaPause Pause btnMultimediaStop Stop Вы можете управлять просмотром или прослушиванием.

BLOB viewer - Viewing as Multimedia

Завершив просмотр данных, Вы можете вернуться к таблице результатов сравнения.

Смотрите также:

Экспорт результатов сравнения


Экспорт результатов сравнения

После завершения сравнения данных на третьем шаге, Вы можете сохранить результаты сопоставления данных в файл. Для этого нужно указать настройки экспорта в окне, открывающемся при нажатии на кнопку btnExportResultList.

Step 3 - Exporting comparison results

Export type

RadioButton Current table - экспортировать только результаты сравнения для текущей таблицы.

RadioButton All Tables - экспортировать результаты сравнения всех таблиц.

Export directory

В этом поле, с помощью кнопки btnExplorer, укажите имя и путь к директории, в которую буду экспортированы данные.

Export format

в этом разделе выберите формат выходного файла.

RadioButton MS Excel

RadioButton RTF

RadioButton HTML

RadioButton MS Excel 2007

В разделе Record types укажите типы записей таблицы сравнения, которые нужно сохранить в файл.

CheckBox Identical records - Записи, идентичные в обеих таблицах [image].

CheckBox Different records - Отличающиеся записи. В некоторых ячейках не совпадает текст [image].

CheckBox Missing records - Записи, не найденные в исходной таблице [image].

CheckBox Additional records - Записи, не найденные в назначенной таблице [image].

CheckBox Open output file after export

Открыть файл, после завершения экспорта.

Нажмите кнопку Export, чтобы начать выполнение операции. На индикаторе выполнения отображается ход выполнения.


Шаг 4 - Задание параметров синхронизации данных

На этом шаге Вы можете задать дополнительные параметры синхронизации данных.

Step 4 - Specifying data synchronization options

Параметры синхронизации таблиц.

RadioButton Synchronize from source to target синхронизировать из исходной в назначенную. Изменения будут внесены в назначенную таблицу.

RadioButton Synchronize from target to source синхронизировать из назначенной в исходную. Изменения будут внесены в исходную таблицу. Она будет приведена к виду назначенной.

CheckBox Synchronize in new table

Установите этот флажок, чтобы создать новую таблицу, которая будет результатом синхронизации. Имя новой таблицы будет составлено из имен исходной и назначенной.

При необходимости, в поле Postfix of new table name Вы можете добавить постфикс к названию таблицы, которая была создана в процессе синхронизации.

CheckBox Insert additional records

Добавить вставить записи, не найденные в назначенной таблице. (Добавить или удалить зависит от того, в какую таблицу сохраняются данные после синхронизации - в исходную или в целевую).

CheckBox Delete missing records

Удалить записи, отсутствующие в исходной таблице. (Добавить или удалить зависит от того, в какую таблицу сохраняются данные после синхронизации - в исходную или в целевую).

CheckBox Update different records

Обновить отличающиеся записи.

CheckBox Drop and create indexes

Эта функция удаляет, а потом заново создает индексы, используя соответствующие операторы SQL. Это позволяет увеличить скорость синхронизации.

Важно: Уберите флажок Synchronize in new table, чтобы активировать эту опцию.

CheckBox Disable triggers

Если установлен этот флажок, то триггеры будут отключены. Это позволит избежать нежелательных действий, которые они могут произвести во время синхронизации данных.

Важно: Уберите флажок Synchronize in new table, чтобы активировать эту опцию.

CheckBox Disable foreign keys

Если установлен этот флажок, то внешние ключи будут отключены.

Важно: Уберите флажок Synchronize in new table, чтобы активировать эту опцию.

Transaction preferences

RadioButton Commit after synchronization

Включите опцию, чтобы фиксация транзакций происходила только после завершения процесса синхронизации. В этом случае у будет возможно откатить все изменения, если в процессе синхронизации произойдет ошибка.

RadioButton Commit after records

После каждого указанного числа записей транзакция будет фиксироваться.

Tables synchronization order

RadioButton Using dependencies

Если опция включена, порядок синхронизации будет определен автоматически, в соответствии с зависимостями таблиц.

RadioButton Manually

Включите опцию, чтобы установить порядок синхронизации таблиц вручную на шаге 5.

CheckBox View synchronization script

Если установлен этот флажок, то Вы сможете просмотреть полученный скрипт на шестом шаге. В противном случае, Вы перейдете сразу к седьмому шагу.

Нажмите кнопку Next, чтобы перейти к следующему шагу.


Шаг 5 - Задание порядка синхронизации таблиц

На данном шаге мастера необходимо задать порядок синхронизации таблиц. Шаг будет пропущен, а порядок установится автоматически, если опция Manual в секции Table synchronization order выключена на шаге 4.

Установите порядок таблиц, используя соответствующие кнопки btnUp и btnDown или перетаскивание.

Step 5 - Setting synchronization order

Для перехода на следующий шаг нажмите кнопку Next.


Шаг 6 - Просмотр и исправление скрипта

Этот шаг позволит Вам просмотреть и отредактировать скрипт синхронизации. Этот шаг доступен, только если установлен флажок CheckBox View synchronization script на четвертом шаге.

Используя редактор скриптов, Вы можете внести изменения и/или добавить комментарии в полученный скрипт.

При необходимости, Вы можете сохранить скрипт во внешний *.sql файл, используя сочетание клавиш Shift+Ctrl+S или кнопку btnSaveScript на панели инструментов.

Step 6 - Editing synchronization script

Функциональные особенности:

  • Подсветка синтаксиса.
  • Code Completion (при вводе первых символов слова, автоматически будет предложен список из слов, начинающихся с этих символов).
  • Нумерация строк.

Контекстное меню Редактора открывается при нажатии правой кнопкой мыши на область редактирования. С его помощью Вы можете выполнять основные операции с текстом скрипта, такие как Копировать, Вставить, Найти, установить закладку, и т.д.

Нажмите кнопку Next, чтобы перейти к следующему шагу.

Смотрите также:

Окно поиска

Окно поиска и замены


Окно поиска

С помощью окна поиска Вы можете найти в тексте Script Editor некоторое сочетание символов.

Чтобы открыть это окно нажмите кнопку Find Text btnFindText на панели инструментов или используйте сочетание клавиш Ctrl+F. Также, эта команда доступна в контекстном меню области редактирования.

Text to find

В это поле вводится искомое сочетание символов.

Из раскрывающегося списка Вы можете выбрать сочетание символов, которое искали до этого.

CheckBox Case sensitive

Учитывать разряд символов при поиске

CheckBox Whole words only

Искать слово целиком

CheckBox Regular expressions

Распознавать регулярные выражения в строке поиска.

В разделе Direction выберите направление поиска.

RadioButton Forward - вперед

RadioButton Backward - назад

RadioButton Global

Искать внутри всей доступной рабочей области.

RadioButton Selected text

Искать только в предварительно выделенном тексте.

В разделе Origin укажите, с какого места следует начать поиск

RadioButton From cursor

От курсора

RadioButton Entire scope

С начала доступной области

CheckBox Mark search result with stack marker

Если флажок установлен, то результаты поиска будут выделены цветом.

Чтобы последовательно отобразить все найденные слова, используйте клавишу Esc.

Нажмите кнопку Show All, чтобы выделить в тексте все результаты поиска.

Смотрите также:

Окно поиска и замены


Окно поиска и замены

В этом окне Вы можете указывать текст в Редакторе, который необходимо найти и текст, которым нужно заменить найденный.

Чтобы открыть это окно нажмите кнопку Replace Text btnReplaceText на панели инструментов или используйте сочетание клавиш Ctrl+R. Также, эта команда доступна в контекстном меню области редактирования.

Text to find

В это поле вводится искомое сочетание символов.

Из раскрывающегося списка Вы можете выбрать сочетание символов, которое искали до этого.

Text to replace

В этом поле укажите то сочетание символов, на которое нужно заменить искомый текст.

CheckBox Case sensitive

Учитывать разряд символов при поиске

CheckBox Whole words only

Искать слово целиком

CheckBox Regular expressions

Искать устойчивое выражение

CheckBox Replace with template

Для использования данной опции необходимо, чтобы опция Regular expressions была включена. Установите флажок для использования регулярных выражений в поле Text to replace. Выражение, указанное в этом поле, будет применено к каждой строке, совпадающей с выражением в поле Text to find.

Важно: Синтаксис регулярных выражений в полях Text to find и Text to replace схож с синтаксисом, используемым в регулярных выражениях Perl. Исчерпывающую информацию вы можете найти здесь: http://perldoc.perl.org/perlre.html#Regular-Expressions.

CheckBox Prompt on replace

Установите этот флажок, если при замене необходимо отображать каждое заменяемое слово. Если флажок не установлен, то замена будет происходить автоматически.

В разделе Direction выберите направление поиска.

RadioButton Forward - вперед

RadioButton Backward - назад

RadioButton Global

Искать внутри всей доступной рабочей области.

RadioButton Selected text

Искать только в предварительно выделенном тексте.

В разделе Origin укажите, с какого места следует начать поиск

RadioButton From cursor

От курсора

RadioButton Entire scope

С начала доступной области

CheckBox Mark search result with stack marker

Если флажок установлен, то результаты поиска будут выделены цветом.

Чтобы последовательно отобразить все найденные слова, используйте клавишу Esc.

Show All, чтобы выделить в тексте все результаты поиска.

Нажмите кнопку Replace All, чтобы автоматически заменить все искомые сочетания символов.

Смотрите также:

Окно поиска


Шаг 7 - Задание дополнительных скриптов

Этот шаг позволяет задать вам скрипты, который будет выполнен для исходной и/или назначенной таблицы перед синхронизацией и после синхронизации.

В верхней и нижней частях формы Before synchronization script и After synchronization script задайте скрипты, которые будут выполняться до и после синхронизации соответственно.

Работать с областью редактирования можно так же, как и с областью редактирования основного скрипта.

Step 7 - Specifying additional scripts

Нажмите кнопку Next, чтобы перейти к последнему шагу мастера.


Шаг 8 - Выполнение операции

Этот шаг информирует Вас о том, что все параметры синхронизации заданы, и Вы можете начать выполнение операции.

CheckBox Abort synchronization on error

Прервать синхронизацию при возникновении ошибки.

CheckBox Detailed error messages

Отображать детальный журнал ошибок.

Step 8 - Start of synchronization process

Если всё указано верно, нажмите кнопку Synchronize.

После завершения процесса синхронизации Вы можете выполнить следующие операции с журналом синхронизации:

  • сохранить журнал во внешний *.rtf файл, используя кнопку Save log btnSaveLog на панели инструментов;
  • напечатать журнал, используя кнопку Print log btnPrintLog на панели инструментов.

Помните: После нажатия на кнопку btnPrintLog печати, программа сохраняет текст лога во временный *.rtf файл, открывает его в редакторе, установленном по умолчанию для данного типа файлов, и затем печатает.

Вы можете сохранить шаблон выполнения операции.


Консольное приложение

Консольное приложение Data Comparer for PostgreSQL предназначено для быстрого и удобного сравнения и синхронизации данных баз данных PostgreSQL, а также для использования в любых планировщиках задач.

Data Comparer for PostgreSQL позволяет сохранять настройки сравнения и синхронизации во внешнем файле шаблона, имеющем расширение *.edc.

Вы можете загрузить предварительно сохраненный шаблон, если хотите внести изменения, или запустить консольное приложениедля выполнения сравнения и синхронизации.

Работа с консольным приложением

Сохранение шаблонов

Загрузка шаблонов

Смотрите также:

Использование мастера

Настройка программы


Работа с консольным приложением

Все параметры сравнения и синхронизации можно сохранить в файл шаблона (*.edc). Консольное приложение использует имя этого файла как параметр при выполнении синхронизации.

Чтобы создать файл конфигурации (шаблон) следуйте инструкции:

  • запустите Data Comparer for PostgreSQL Мастер сравнения и синхронизации данных;
  • задайте необходимые параметры на каждом шаге;
  • проверьте сравнение и синхронизацию на последнем шаге
  • сохраните шаблон.

Запустить файл конфигурации можно тремя способами:

  • использовать пункт Load Template из списка, открывающегося при нажатии на кнопку Tools.
  • дважды щелкнуть на созданном файле конфигурации (*.edc) мышью.
  • задать в консольном приложении команду запуска - <path to Data Comparer for PostgreSQL console application>\PgDataComparerC.exe TemplateFile [-L] [-B]

Пример:

<path to Data Comparer for PostgreSQL console application>\PgDataComparerC.exe TemplateFile [-L] [-B]

TemplateFile

Имя файла конфигурации *.edc и путь к нему.

[-L]

Выберите текущую локализацию.

[-B]

Используйте этот параметр, если хотите запустить процесс в фоновом режиме.

[-LOG]

Данный параметр задает путь к файлу журнала. По умолчанию журнал создается в папке программы.

Пример:

"C:\Program Files\EMS\Data Comparer for PostgreSQL\PgDataComparerC.exe" "C:\EMS\DataComparer\1st_sync.edc" -L -LOG"C:\Logs\datacomparer.log"

Важно: Следующие значения кода завершения возвращаются программой Data Comparer for PostgreSQL операционной системе после выполнения последней операции:

0 - удачное завершение;

1 - во время выполнения произошла ошибка или ошибки;

Смотрите также:

Использование мастера

Формат файла конфигурации


Сохранение шаблонов

Шаблоны сохраняются с помощью специального диалогового окна Save template options, которое открывается при выборе пункта Save template из раскрывающегося списка, появляющегося при нажатии кнопки Tools.

Сохранять шаблон можно на любом шаге.

Параметры сохранения шаблона

В окне Save template options Вы можете конфигурировать шаблон.

Using templates - Save template options

File name

Имя и путь к файлу шаблона укажите в этом поле, с помощью кнопки btnSaveAs.

Comment

При необходимости, снабдите файл комментарием.

Console options

Вы можете сохранить скрипт в файл с расширением *.sql, установив флажок CheckBox Save script to file и указав имя и путь к файлу, в поле Script file name.

CheckBox Execute script after creating

Если этот флажок установлен, то скрипт, сразу же после создания, будет выполнен консольным приложением.

Важно: Невозможно установить этот флажок, если установлен Save script to file.

CheckBox Fill correspondence automatically

Если этот флажок установлен, то консольное приложение не учитывает настройки, заданные на Шаге 2, и устанавливает соответствие таблиц автоматически.

Password options

CheckBox Save password in template

Установите этот флажок, чтобы пароль базы данных был сохранен в файле шаблона.

Если этот флажок не установлен, то пароль будет запрашиваться при загрузке шаблона.

CheckBox Encrypt password

Если установлен этот флажок, то пароль в шаблоне будет храниться в зашифрованном виде.

Смотрите также:

Загрузка шаблонов

Формат файла конфигурации


Загрузка шаблонов

Меню, позволяющее выбирать действия для работы с шаблонами, открывается при нажатии на раскрывающийся список кнопки Tools.

Шаблоны Data Comparer загружаются при помощи диалогового окна, открывающегося при выборе пункта Load template.

Вы можете открыть шаблон заново, выбрав нужный из списка Reopen template.

Clear template list - очистить список шаблонов.

Clear not existing templates - удалить из списка ссылки на несуществующие шаблоны.

Когда выбран шаблон, Вы сразу переходите к шагу Просмотр и исправление скрипта. При необходимости, Вы можете вернуться на предыдущие шаги и изменить настройки операции.

Смотрите также:

Сохранение шаблонов


Настройка программы

Вы можете полностью настроить интерфейс программы с помощью инструмента Preferences.

Чтобы открыть окно Preferences необходимо на любом шаге мастера нажать кнопку Tools и из появившегося списка выбрать пункт Preferences.

Основные элементы управления располагаются на следующих вкладках:

General

На этой вкладке задайте основные опции программы.

Directories

На этой вкладке задайте директорию, в которую будет выгружаться кэш.

Language

Язык интерфейса программы укажите на этой вкладке.

Data fonts

Вы можете задать шрифт для отображения данных на третьем шаге мастера.

Interface

На вкладках раздела Interface Вы можете указать стиль отображения таких элементов интерфейса, как кнопки, флажки и т.д.

Смотрите также:

Использование мастера

Использование шаблонов


Задание основных параметров

На этой вкладке задайте основные опции программы.

Preferences - General

CheckBox Remember password

Помнить пароль (пароли) для доступа к базе данных.

CheckBox Encrypt password in registry

Хранить в реестре зашифрованный пароль. Эта опция доступна, только если вы сохраняете пароль.

CheckBox Show table definition hints

С помощью этой функции Вы можете включить или выключить отображение всплывающих подсказок для таблиц, которые появляются при наведении курсора на заголовок таблицы на шаге установки соответствия полей. В подсказках содержится DDL описание таблиц.

CheckBox Save current options on exit

Сохранить настройки. Если установлен этот флажок, то все указанные настройки будут отображаться при следующем запуске программы.

CheckBox Show summary dialog after comparison

Включите опцию, если хотите чтобы после процедуры сравнения на шаге 2 появлялся диалог Summary, отображающий краткую информацию о результатах сравнения таблиц.

CheckBox Disable code folding in editors - отключить возможность задания иерархической структуры текста скрипта с возможностью скрывать подобъекты (Code folding) в редакторах.

CheckBox Show schema selection dialog

Если этот флажок установлен, то на втором шаге мастера будет отображаться окно, позволяющее выбрать схемы, которые нужно обновить.

Messages

CheckBox Confirm exit

Если при выходе из программы необходимо запрашивать подтверждение, то установите этот флажок.

CheckBox Show complete message

Отображать сообщение о завершении процесса синхронизации таблиц на шаге Выполнения операции.

CheckBox Show all identical tables warning

Показывать предупреждение, если сравниваемые таблицы идентичны.

CheckBox Confirm re-compare

С этой опцией, при повторной попытке сравнить данные (например, когда вам нужно вернуться на второй шаг, чтобы изменить соответствие таблиц и/или полей) Вам будет предложено подтвердить действие.

CheckBox Show trigger disabling dialog

Если опция включена, то после четвертого шага будет появляться диалог, запрашивающий блокирование триггеров при синхронизации.

Смотрите также:

Директории

Выбор языка программы

Шрифты

Выбор интерфейса


Директории

CheckBox Use custom directory for cache

Если установлен этот флажок, то кэш будет загружен в папку, указанную в поле Cache directory. Это рекомендуется делать при нехватке свободного места на системном диске.

Если опция Use custom directory for cache отключена, то кэш будет по умолчанию помещаться в папку Temp текущего пользователя.

Preferences - Directories

Смотрите также:

Задание основных параметров

Выбор языка программы

Шрифты

Выбор интерфейса


Выбор языка программы

С помощью инструментов, расположенных на этой вкладке Вы можете задавать язык программы.

В списке Languages показан список доступных локализаций, которые можно установить как основной язык программы.

Preferences - Localization

Вы можете выбрать один из предложенных языков, или создать свой файл локализации*.lng подобно тем, которые лежат в папке %program_directory%\Languages. Для того чтобы ваш файл локализации появился в списке необходимо разместить его в папке Languages.

Смотрите также:

Задание основных параметров

Директории

Шрифты

Выбор интерфейса


Шрифты

На вкладке Data Fonts Вы можете задать шрифт для отображения данных на третьем шаге мастера.

Preferences - Data fonts

Из раскрывающегося списка Font выберите шрифт, а из списка Charset - кодировку.

Смотрите также:

Задание основных параметров

Директории

Выбор языка программы

Задание параметров интерфейса


Выбор интерфейса

На вкладке Interface Вы можете выбрать схему оформления внешнего вида элементов управления программы.

Из раскрывающегося списка Scheme name можно выбрать один из следующих стилей:Office 11, Office XP, Office 2k Windows XP and Classic.

Preferences - Interface

В окне отображаются примеры оформления в зависимости от выбранного стиля.

Смотрите также:

Задание основных параметров

Директории

Выбор языка программы

Шрифты


Параметры SSH туннелирования

SSH (Secure Shell Host) протокол используется для повышения компьютерной безопасности при работе Unix-системами в Internet. SSH использует несколько алгоритмов шифрования разной степени надежности. Распространенность SSH связана еще и с тем, что многие Linux-подобные ОС (например, FreeBSD) включают в стандартную комплектацию SSH сервер. Для получения дополнительной информации Вы можете посетить http://openssh.org. Опция SSH туннель представляет собой средство организации безопасного доступа к PostgreSQL серверам при работе по небезопасным каналам связи. Также Вы можете использовать SSH туннель для доступа к удаленным PostgreSQL серверам, если по каким-либо причинам порт 3306 закрыт для внешних подключений. Соединение через SSH туннель выглядит следующим образом. Сначала устанавливается соединение и производится процедура аутентификации между встроенным в Data Comparer for PostgreSQL SSH клиентом и удаленным SSH сервером, затем вся исходящая и входящая информация между программой и PostgreSQL сервером передается через SSH сервер с использованием коммуникационного порта (обычно 22), а SSH сервер транслирует информацию уже непосредственно PostgreSQL серверу. Чтобы зарегистрировать базу данных, соединение к которой должно выполняться с использованием SSH туннеля, Вы должны задать следующие параметры при регистрации базы данных в PostgreSQL:

SSH Host - имя машины (IP-адрес), на которой установлен сервер SSH.

SSH Port - порт SSH сервера на удаленном хосте.

SSH User Name - имя пользователя на сервере (пользователь SSH сервера, а не сервера PostgreSQL).

SSH Password - идентификационная фраза (passphrase) пользователя SSH сервера.

SSH Private Key - Passphrase

Имейте в виду, что в случае использования SSH туннелирования имя хоста PostgreSQL должно быть задано относительно сервера SSH. Например, если PostgreSQL и SSH сервер установлены на одном компьютере, следует указать 'localhost' в качестве имени хоста вместо имени внешнего хоста или IP адреса.


Параметры HTTP туннелирования

HTTP туннелирование - это способ, при котором соединение и передача данных между программой и PostgreSQL сервером происходит через протоколы HTTP/HTTPS, используя порт 80, через который работает обычный веб-браузер. Этот способ подходит для соединения с PostgreSQL, расположенным на удаленным сервере хостинг провайдера, когда прямое соединение невозможно из соображений безопасности. Соединение через HTTP туннель выглядит следующим образом: все исходящие запросы и команды с клиентских программ кодируются и передаются по протоколу HTTP/HTTPS, используя порт 80, специальному скрипту, который декодирует их и передает PostgreSQL серверу на обработку, и возвращает обратно результат. Для использования этого способа на удаленном сервере должен быть установлен HTTP сервер (например, Apache) и PHP с подключенным расширением PostgreSQL. Как правило, это программное обеспечение предлагают все хостинг-провайдеры, предоставляющие услуги хостинга на Linux платформах. Кроме того, Вы должны разместить наш emsproxy.php скрипт на вашем веб-сервере так, чтобы иметь к нему доступ извне (например, поместить его в каталог, где находятся ваши остальные PHP скрипты). Если ваш веб-сервер удовлетворяет данным требованиям и скрипт установлен правильно, то при открытии http://<your_webserver_name>/emsproxy.php в веб-браузере Вы увидите “EmsProxy v1.31” (версия может меняться).

URL - это адрес, где находится скрипт emsproxy.php (например, http://webserver_name/emsproxy.php).


Формат файла конфигурации

Файл конфигурации (шаблон) используемый Data Comparer for PostgreSQL состоит из нескольких разделов, каждый из которых соответствует конкретной группе настроек, указанных на разных шагах Мастера сравнения и синхронизации данных.

[#General#]

В этом разделе хранятся общие сведения об утилите:

Параметр | Описание
Product | внутреннее название продукта
Version | версия

[#SourceDB#]

В этом разделе хранятся параметры подключения к источнику данных. Эти параметры указываются на Первом шаге Мастера и являются обязательными для заполнения.

Параметр | Описание
Host | хост, где находится источник данных (если Удаленный, то значение параметра = 1)
Port | порт
Remote | 0 = локальное соединение 1 = удаленное соединение
DBName | База данных - источник данных
Login | логин
Password | пароль для идентификации входа (с шифрованием)
Charset | кодировка
FontCharset | Параметр не используется Data Comparer for PostgreSQL

TunnelType | тип туннелирования: SSH, HTTP, или без туннелирования (TunnelType = ttNotUse)
SSHHostName | имя сервера, на котором запущен SSH сервер
SSHPort | порт SSH сервера на удаленном хосте
SSHUserName | имя пользователя на сервере (пользователь SSH сервера, а не сервера PostgreSQL)
SSHPassword | идентификационная фраза (passphrase) пользователя SSH сервера
SSHKeyFile | путь к Ключевому файлу, используемому для подключения (если SSHUseKeyFile = True)
SSHUseKeyFile | True = SSH Private Key используется False = SSH Private Key не используется
HTTPUrl | это адрес, где находится скрипт emsproxy.php (для HTTP туннелирования)

[#TargetDB#]

В этом разделе хранятся параметры подключения для назначенной базы данных. Параметры соответствуют значениям на Первом шаге Мастера и являются обязательными для заполнения. Набор параметров такой же, как и для исходной базы данные. ([#SourceDB#]).

[#Options#]

в этом разделе находятся параметры сравнения данных, соответствующие тем, которые задаются на втором и третьем шагах Мастера сравнения и синхронизации данных.

Параметр | Описание
Blobs | Установите этот флажок, если хотите, чтобы поля BLOB сравнивались. 0 = поля BLOB не сравниваются 1 = поля BLOB сравниваются
IgnoreCase | 0 = учитывается регистр символов при сравнении 1 = не учитывается регистр символов при сравнении
FillIdentical | 0 = идентичные записи не отображаются на третьем шаге. 1 = идентичные записи отображаются на третьем шаге
ViewRecordsCount | Число записей, отображающихся на одной странице на Шаге 3
ThreadCount | число потоков сравнения
SavePassword | 0 = пароль не сохраняется в файле шаблона 1 = пароль сохраняется в файле шаблона
PasswordEncripted | 0 = пароль будет храниться не в зашифрованном виде в файле шаблона 1 = пароль будет храниться в зашифрованном виде в файле шаблона
TrimCharFields | 0 = пробелы в конце строк для CHAR полей не будут удаляться 1 = пробелы в конце строк для CHAR полей будут удаляться
CompareOnServerSide | 0 = сравнение проводится на стороне клиента 1 = сравнение проводитсяф на сервере

[#SyncOptions#]

В этом разделе содержатся параметры, с помощью которых Вы можете задать настройки синхронизации таблиц. Эти параметры соответствуют тем, которые расположены четвертом, пятом, шестом и седьмом шагах Мастера сравнения и синхронизации данных.

Параметр | Описание
TargetToSource | 0 = синхронизировать из исходной в назначенную. Изменения будут внесены в назначенную таблицу. 1 = синхронизировать из назначенной в исходную. Изменения будут внесены в исходную таблицу.
TablePostfix | постфикс, добавляемый к названию таблицы, которая была создана в процессе синхронизации (если SyncInNewTable = 1), по умолчанию _sync
SaveScript | 0 = скрипт синхронизации сохраняется во внешний файл как шаблон 1 = скрипт синхронизации не сохраняется
ScriptFileName | путь к файлу, в который будет сохранен скрипт синхронизации (если параметр SaveScript = 0)
InsertMissRecs | 0 = пропущенные записи игнорируются в процессе синхронизации 1 = пропущенные записи добавляются в таблицу при синхронизации
DeleteAddRecs | 0 = новые записи игнорируются в процессе синхронизации 1 = новые записи удаляются в процессе синхронизации
UpdateDiffRecs | 0 = отличающиеся записи игнорируются в процессе синхронизации 1 = отличающиеся записи обновляются в процессе синхронизации
SyncInNewTable | 0 = синхронизация производится в существующую таблицу (TargetToSource = 1 или 0) 1 = создается новая таблица, в которую помещают синхронизированные данные
LoadToScriptEditor | 0 = скрипт синхронизации не загружается в редактор скриптов 1 = скрипт синхронизации не загружается в редактор скриптов и отображается на пятом шаге.
AbortExecuteOnError | 0 = процесс синхронизации не прерывается при возникновении ошибки 1 = процесс синхронизации прерывается при возникновении ошибки
DetailErrors | 0 = не отображается детальный журнал ошибок 1 = отображается детальный журнал ошибок на седьмом шаге
ExecuteScript | 0 = скрипт синхронизации не выполняется автоматически 1 = скрипт синхронизации выполняется автоматически консольным приложением после создания шаблона
DropIndexes | 0 = индексы таблицы не учитываются 1 = индексы таблицы удаляются, потом создаются заново
CommitAlter | После каждого указанного числа записей транзакция будет фиксироваться.
Autofill | 0 = не устанавливать автоматически соответствие таблиц при сравнении 1 = устанавливать автоматически соответствие таблиц при сравнении

[#Comment#]

В этом разделе содержатся комментарии к файлу шаблона:

Параметр | Описание
Line<N> | текст комментариев

N - номер строки

Пример:

Line0=Data Comparer for PostgreSQL

Line1=Template file

Line2=Data synchronization #1

[#SrcAfterScript#]

В этом разделе содержится скрипт, который выполняется для исходной базы данных после синхронизации. Этот скрипт Вы можете указать на шестом шаге Мастера сравнения и синхронизации данных.

Параметр | Описание
Item_Count | число строк
Line<N> | текст скрипта

N идентифицирует строки скрипта

Пример:

Item_Count=2

Line0=/*AFTER synchronization*/

Line1=/*script to be executed for the source database*/

[#TrgAfterScript#]

В этом разделе содержится скрипт, который выполняется для назначенной базы данных после синхронизации. Этот скрипт Вы можете указать на шестом шаге Мастера сравнения и синхронизации данных.

Параметр | Описание
Item_Count | число строк
Line<N> | текст скрипта

N идентифицирует строки скрипта

Пример:

Item_Count=2

Line0=/*AFTER synchronization*/

Line1=/*script to be executed for the target database*/

[#SrcBeforeScript#]

В этом разделе содержится скрипт, который выполняется для исходной базы данных перед синхронизацией. Этот скрипт Вы можете указать на шестом шаге Мастера сравнения и синхронизации данных.

Параметр | Описание
Item_Count | число строк
Line<N> | текст скрипта

N идентифицирует строки скрипта

Пример:

Item_Count=2

Line0=/*BEFORE synchronization*/

Line1=/*script to be executed for the source database*/

[#TrgBeforeScript#]

В этом разделе содержится скрипт, который выполняется для назначенной базы данных перед синхронизацией. Этот скрипт Вы можете указать на шестом шаге Мастера сравнения и синхронизации данных.

Параметр | Описание
Item_Count | число строк
Line<N> | текст скрипта

N идентифицирует строки скрипта

Пример:

Item_Count=2

Line0=/*BEFORE synchronization*/

Line1=/*script to be executed for the target database*/

[SrcSchemas]

Список схем, задающихся для сравнения.

Параметр | Описание
Item_Count | количество схем
Line<N> | имя схемы

N - идентификатор схемы в списке

Пример:

Item_Count=1

Line0=DEMO

[TrgSchemas]

Список выбранных для сравнения схем.

Параметр | Описание
Item_Count | количество схем
Line<N> | имя схемы

N - идентификатор схемы в списке

Пример:

Item_Count=2

Line0=TEST

Line1=PRODUCTION

[Table<N>]

В этом разделе указываются соответствия таблиц и полей. Эти параметры можно задать на втором шаге Мастера сравнения и синхронизации данных.

Параметр | Описание
#SourceTable# | имя исходной таблицы
#TargetTable# | имя назначенной таблицы
Synchronize | 0 = таблицы не будут синхронизированы 1 = таблицы #SourceTable# и #TargetTable# будут синхронизированы
#SourceOwner# | схема/владелец исходной таблицы (#SourceTable#)
#TargetOwner# | схема/владелец назначенной таблицы (#TargetTable#)
<field_name> | соответствующие поля таблиц
<field_name>_CompareKey | 0 = поле не используется в качестве ключевого при сравнении 1 = поле используется в качестве ключевого при сравнении

Пример:

[Table0]

#SourceTable#=EMPLOYEE

#TargetTable#=EMPLOYEE_UPD

Synchronize=1

#SourceOwner#=DEMO

#TargetOwner#=PRODUCTION

EMP_ID=EMP_NO

EMP_ID_CompareKey=1

FIRST_NAME=FIRST_NAME

FIRST_NAME_CompareKey=0

LAST_NAME=LAST_NAME

LAST_NAME_CompareKey=0


Дополнительные настройки подключения

Для подключения к серверу Oracle необходимо, чтобы на компьютере, на котором будет использоваться Data Comparer for PostgreSQL, был установлен клиент Oracle. Версия клиента Oracle должна быть совместима с версией сервера Oracle, к которому необходимо подключиться.

Необходимо добавить параметры подключения баз данных Oracle в ваш TNS names файл (tnsnames.ora файл). Это конфигурационный файл, который содержит описания баз данных.

Если Вы используете Database Client, то файл tnsnames.ora находится в директории %HOME_name\NETWORK\ADMIN.

Если Вы используете Instant Client, то файл tnsnames.ora необходимо будет создать вручную. Файл должен быть создан в той же директории, в которой установлен Oracle клиент (например, C:\OracleInstantClient\). Этот файл можно создать с помощью любого текстового редактора (создать простой текстовый файл, а затем изменить его название и расширение).

Только для Instant Client

После того как файл tnsnames.ora создан, и добавлено описание базы данных, необходимо создать переменную окружения TNS_ADMIN.

Для этого необходимо выполнить следующие действия.

  1. Щелчком правой кнопки мыши на значке My computer/Мой компьютер вызовите контекстное меню.
  2. В этом контекстном меню выберите пункт Properties/Свойства.
  3. Перейдите на вкладку Advanced/Дополнительно и нажмите кнопку Environment Variables/Переменные среды.
  4. В разделе System variables/Системные переменные нажмите кнопку New.../Создать.
  5. В поле Variable name/Имя переменной задайте TNS_ADMIN, а в поле Variable value:/Значение переменной задайте C:\OracleInstantClien\tnsnames.ora.
  6. Нажмите кнопку OK и сохраните переменную.

В этом же диалоговом окне найдите переменную PATH. Двойным щелчком откройте её для редактирования в специальном окне и добавьте путь к клиентским библиотекам клиента Oracle Instant. (Они расположены в каталоге, где установлен клиент C:\OracleInstantClient\). Помните, что записи путей должны быть разделены точкой с запятой (;).

Data Comparer for PostgreSQL подключается к серверу (с помощью клиента) через TCP/IP протокол.

Пример настроек подключения, заданных в TNS файле.

DB_Alias =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP)(HOST = Host_name)(PORT = 1521))

)

(CONNECT_DATA =

(SERVER = DEDICATED)

(SERVICE_NAME = Database_Name)

)

)

Параметры:

PROTOCOL - конкретный протокол, используемый адаптером. Для этого параметра значение протокола - TCP. Значение может быть введено в верхнем или нижнем регистре.

HOST - имя сервера или IP адрес.

PORT - номер порта TCP/IP.

SERVICE_NAME - имя службы сервера; имя экземпляра базы данных может отличаться от фактического имени базы данных.

DB_Alias - ​​любое имя подключения.

На первом шаге из раскрывающегося списка Database home выберите имя клиента и раскрывающегося списка Database можно будет выбрать одну из баз данных, указанных в файле tnsnames.ora.